Connect Method

Post your HomeSeer plug-in comments and feedback here.

Connect Method

Postby cbalas » Sun Mar 11, 2012 9:23 am

Hello,
It seems that in the settings for HS Mobilinc I cannot connect to the prefer method if I have the settings at "Auto-Detect". From in my home on my wireless network , I have to have it set at "HTTP" for it to connect. on 3G, outside my home, I can have it set at "HTTPS", or "Auto detect". But if I leave it on auto detect, it doesn't work inside my home. Am I doing something wrong?
Thanks.
cbalas
 
Posts: 3
Joined: Sun Mar 11, 2012 9:09 am

Re: Connect Method

Postby AdminWes » Sun Mar 11, 2012 11:13 am

Hi cbalas,

What OS are you running HomeSeer on? If Windows XP, the MobiLinc plug-in will not broadcast itself on the LAN for the Auto-Detect feature. However, this shouldn't break anything. See the following:

If you have the remote access working as it sounds like you do then you've got the port forwarding all setup and configured correctly. HTTPS should work inside of your home IF your router supports IP loopback. Most routers do unless you are using an older router or an out-of-date router firmware.

My guess is that the Auto-Detect is showing HTTPS when inside of your home. That's ok and should work assuming that IP Loopback is supported in your router.

Wes
AdminWes
Site Admin
 
Posts: 2131
Joined: Sat Feb 07, 2009 2:52 pm

Re: Connect Method

Postby cbalas » Mon Mar 12, 2012 4:48 pm

Hi Wes,
Thanks for the quick reply. The "Auto Detect" is showing "Https" when inside my home but it will not connect until I change it to Http. Maybe my router ( D-link DIR-655) does not support loopback. I'll have a look at the configuration.
cbalas
 
Posts: 3
Joined: Sun Mar 11, 2012 9:09 am

Re: Connect Method

Postby AdminWes » Tue Mar 13, 2012 7:11 am

Hi cbalas,

Just poking around on Google, the consensus is that the router you listed here does not support IP Loopback which would explain what you are seeing: http://hardforum.com/showthread.php?t=1257761

I think your options are either to pickup a router that does support loopback or go into MobiLinc and change the Connect Method to HTTP or HTTPS when you are at home or away. Or, setup two profiles in MobiLinc. One for when you are at home using HTTP, and one when you are away using HTTPS over your external IP address. Then you just have to switch profiles instead of changing out the connection settings and resyncing each time.

Wes
AdminWes
Site Admin
 
Posts: 2131
Joined: Sat Feb 07, 2009 2:52 pm

Re: Connect Method

Postby cbalas » Tue Mar 13, 2012 4:14 pm

Thanks Wes,
I'll try the 2 profiles, that should work well enough.

cbalas
cbalas
 
Posts: 3
Joined: Sun Mar 11, 2012 9:09 am


Return to HomeSeer Plug-in Feedback and Comments

Who is online

Users browsing this forum: No registered users and 1 guest