Where are the devices

Submit feedback, comments, and support help here.

Where are the devices

Postby stusviews » Wed Nov 23, 2011 9:04 pm

I have nearly 40 primary devices, but only 4 appear in the My Devices panel.
stusviews
 
Posts: 12
Joined: Wed Nov 23, 2011 7:40 pm

Re: Where are the devices

Postby AdminWes » Thu Nov 24, 2011 8:02 am

MobiLinc scans the SmartLinc's link table and pulls in every link record that the SmartLinc knows about.

Do you know if every one of the 40 devices was linked specifically to the SmartLinc or just other devices? If there are INSTEON devices in your network that are not linked to the SmartLinc then MobiLinc will be unable to find these devices and will need to be entered by hand into MobiLinc. Or, if you link each device to the SmartLinc (creating a link record in the SmartLinc) and sync MobiLinc to the SmartLinc under My Devices->Lighting Controller->Sync then MobiLinc will pull in the additional devices.

Wes
AdminWes
Site Admin
 
Posts: 2096
Joined: Sat Feb 07, 2009 2:52 pm

Re: Where are the devices

Postby stusviews » Thu Nov 24, 2011 2:57 pm

I have considerably more devices linked than what I'm referring to as Primary devices. Primary devices are those that show their status in SmartLinc. Each was specifically linked to the SmartLinc as a responder using HouseLinc.

My Setting->Lighting Controller->Sync removed the I/O Lincs I added. Only four devices appear in My devices.
stusviews
 
Posts: 12
Joined: Wed Nov 23, 2011 7:40 pm

Re: Where are the devices

Postby AdminWes » Fri Nov 25, 2011 7:51 am

Thanks for the details.

Here's where I think the problem is. By putting in the INSTEON device ID in the scene for reporting status, that doesn't update or change the SmartLinc's link table and thus does not inform MobiLinc that there is a primary device out there.

Your method of using HouseLinc to link the devices to the SmartLinc is interesting. I can't say I've done that or heard of others do that so I'm not sure what kind of link HouseLinc is writing to the SmartLinc. Here's my guess, the normal way is to use the web interface and setup a new scene with the SmartLinc. You click on Add Device and that puts the SmartLinc into linking mode. You then add the device to the scene by pressing and holding its button to force a link to be created in the SmartLinc and the device for that scene.

Now, with HouseLinc in the mix, I don't know what it's writing if anything to the SmartLinc link table. Can you try linking a device to a scene as described above using the SmartLinc web interface to see if that works to get your devices added to MobiLinc?

Or what other link options does HouseLinc have with the SmartLinc? Can you tell the SmartLinc to be a controller and a responder to each of your devices in your home? Using HouseLinc can you dump out the link record database of the SmartLinc to see what's in there?

Wes
AdminWes
Site Admin
 
Posts: 2096
Joined: Sat Feb 07, 2009 2:52 pm

Re: Where are the devices

Postby stusviews » Fri Nov 25, 2011 7:14 pm

Unless specifically changed, the Report Status ID is that of the first device added using manual tapping. Any ID can be placed there, it is independent of any SmartLinc links.

It is "normal" to use HouseLinc to create, modify, and/or delete SmartLinc links. The links created by HouseLinc are identical to manual linking. SmartLinc can be a controller, but not a responder (except for status response, but even a non-linked device ID can be used).

Of the four devices that appear in My Devices, only one was linked manually. The other three were linked using HouseLinc - and none of the devices are set to show their status in SmartLinc. In particular, what I refer to as Primary Devices are those that have a load connected. About a half-dozen devices were initially linked manually.

BTW, I'm an experienced Insteon user (since its inception), almost 90 devices, nearly 4500 posts on the SmartLinc forum. Just so you know ;)
stusviews
 
Posts: 12
Joined: Wed Nov 23, 2011 7:40 pm

Re: Where are the devices

Postby AdminWes » Sat Nov 26, 2011 9:05 am

4500? Wow, that's a few posts.

I'm am at a complete loss as to why those links aren't showing up in MobiLinc. What MobiLinc does is it asks the SmartLinc for the next link in the link database. The SmartLinc will send a link to MobiLinc each time requests until the SmartLinc thinks there are no more links to send at which point it tells MobiLinc "No More Links" and MobiLinc moves on. I suspect the SmartLinc is telling MobiLinc "No More Links" prematurely OR that 5th link record is corrupted and throwing the whole process off.

Would it be possible for me to sync with your SmartLinc so I can step through the syncing code in my lab setup to see what your SmartLinc is exactly returning to MobiLinc? I could also use this to diagnose why your 2nd Thermostat doesn't add correctly. In every one of my tests here the 2nd thermostat is added to My Thermostats and I can't reproduce what you are seeing.

If this would be OK, please send me your connection information to wes@mobileintegratedsolutions.com

Thanks,
Wes
AdminWes
Site Admin
 
Posts: 2096
Joined: Sat Feb 07, 2009 2:52 pm

Re: Where are the devices

Postby stusviews » Sat Nov 26, 2011 5:03 pm

Done. Much thanks.
stusviews
 
Posts: 12
Joined: Wed Nov 23, 2011 7:40 pm

Re: Where are the devices

Postby AdminWes » Mon Nov 28, 2011 8:40 am

As a follow-up to close out this forum topic, Stu was kind enough to allow me to access his SmartLinc. The issue appears to be that the SmartLinc is reporting the device types as something other than a ON/OFF Switch, dimmer, IOLinc, Irrigation Controller, or iMeterSolo. As a result, MobiLinc won't add unknown device links into the MobiLinc database as the device type must be known for MobiLinc to understand the device's capability and how to talk to that device.

I confirmed with Stu that these devices are indeed ON/OFF or dimming devices, but for some reason the SmartLinc has recorded the link Primary Type of these devices incorrectly and thus is preventing MobiLinc from importing them into its internal database.

Wes
AdminWes
Site Admin
 
Posts: 2096
Joined: Sat Feb 07, 2009 2:52 pm


Return to MobiLinc Feedback and Comments

Who is online

Users browsing this forum: No registered users and 2 guests

cron