Force Close: Cannot access My Settings on Android 4.2

Submit your bug reports here.

Force Close: Cannot access My Settings on Android 4.2

Postby akula34 » Sun Nov 25, 2012 5:58 pm

I cannot access My Settings on Android 4.2. I am running 1.2.1.

Every time I open it, it hangs on Processing Profile Change and eventually stops responding.

I cannot change any settings! Help!

Luke
Attachments
Screenshot_2012-11-25-19-39-29.jpg
Screenshot of the Error
Screenshot_2012-11-25-19-39-29.jpg (146.66 KiB) Viewed 10936 times
akula34
 
Posts: 11
Joined: Thu Nov 01, 2012 8:45 am

Re: Force Close: Cannot access My Settings on Android 4.2

Postby AdminWes » Sun Nov 25, 2012 6:43 pm

Luke,

Please see this long forum post that details our debugging attempts to find the root cause of this issue.

viewtopic.php?f=46&t=2449

By around page 3 we started to figure out that there is something going on inside of the OS that's causing this problem. The bottom line is we were unable to address the OS execution problem in the app code (we were never able to reproduce the issue on our end). The issue appears to be inside of the OS where only a factory data reset worked for 2 of the 3 users that saw it.

Wes
AdminWes
Site Admin
 
Posts: 2040
Joined: Sat Feb 07, 2009 2:52 pm

Re: Force Close: Cannot access My Settings on Android 4.2

Postby akula34 » Fri Dec 07, 2012 6:37 pm

This is definitely something going on with how your program interacts with Android 4.2. I just got a stock Nexus 4 in the mail yesterday, and I'm getting the same problem as I had with my Galaxy Nexus.

The program works fine, but I cannot access the settings. It's kinda a pain.

No one else is seeing this behavior? How many 4.2 users do you have out there?

Luke
akula34
 
Posts: 11
Joined: Thu Nov 01, 2012 8:45 am

Re: Force Close: Cannot access My Settings on Android 4.2

Postby AdminWes » Sat Dec 08, 2012 1:11 pm

Luke,

We're taking reports on this issue trying to determine why a subset of users have this problem. We have many 4.2 users with no issues at all.

Google changed many things with how apps are installed on 4.1 and 4.2 and we suspect there is something there. Do you have device encryption turned on?

Wes
AdminWes
Site Admin
 
Posts: 2040
Joined: Sat Feb 07, 2009 2:52 pm

Re: Force Close: Cannot access My Settings on Android 4.2

Postby ryanwagner » Fri Dec 14, 2012 9:44 am

Same issue. I had everything working fine on my rooted Nexus 4 (running stock 4.2.1), but I had done a few things that made me want to wipe the device. So I wiped the device and started fresh. Installed MobiLinc , and went to set it up again. I was prompted with the "MobiLinc Connect" box, which I don't need, so I pressed "No Thanks". I clicked over to "My Settings" and the "MobiLinc Connect" box jumped back up, but I couldn't press any of the buttons this time. It then started to flicker between the "MobiLinc Connect" box and the "My Settings" page with the "processing profile change" popup displaying periodically. Eventually it stopped responding.

I've tried resinstalling many times, but no luck. I even have a backup from Titanium Backup that I tried to restore. When restoring the backup the app has all of my data and everything can be controlled just fine. If I go to the "My Settings" I run into the same issue where the "processing profile changes" screen appears. To make things even more interesting I cannot create new widgets when this happens. I'm normally able to get through a couple of the menu options (selecting to create a scene widget, selecting the scene...), but by the time I get to the end everything freezes and the menus reset.

Edit: and I do not have device encryption turned on.
ryanwagner
 
Posts: 8
Joined: Mon Dec 03, 2012 11:02 am

Re: Force Close: Cannot access My Settings on Android 4.2

Postby AdminWes » Fri Dec 14, 2012 10:27 am

Thanks Ryan for the report. Appreciate the details. This continues to help us isolate where the issue is.

We're still investigating, but looking for more users to report what they've tried, haven't tried to continue to narrow in on why only some 4.1/4.2 users have an issue. Especially with a backup from an older version.

Wes
AdminWes
Site Admin
 
Posts: 2040
Joined: Sat Feb 07, 2009 2:52 pm

Re: Force Close: Cannot access My Settings on Android 4.2

Postby arw01 » Fri Dec 14, 2012 2:53 pm

Some with the issue should run logcat as well for you.

Also are you having people stop the app, flush it's cash and data, and then trying the app again or uninstalling then, rebooting, and seeing if the issue returns?

With a rooted phone you could have a customer send you the files to see if they are corrupt or not.
arw01
 
Posts: 32
Joined: Sun Dec 09, 2012 12:05 pm

Re: Force Close: Cannot access My Settings on Android 4.2

Postby AdminWes » Fri Dec 14, 2012 4:19 pm

Yes, we've tried just about everything including completely removing the app and flushing the cache and data. The only thing we've seen work part of the time is to do a Factory Data Reset on the device.

We ran a Logcat a few months ago and saw that the code execution that was happening on these device that have the issue shouldn't be possible. The code in this area is simple, not at all complex so seeing the execution not behave is very questionable as to the device or installation integrity.

We still haven't been able to reproduce this issue in the lab on our 4.1 and 4.2 devices.

Wes
AdminWes
Site Admin
 
Posts: 2040
Joined: Sat Feb 07, 2009 2:52 pm

Re: Force Close: Cannot access My Settings on Android 4.2

Postby arw01 » Sat Dec 15, 2012 9:47 am

I had a program on my son's tablet that would just never connect to do in app purchases. It took a re-install of the factory update software to resolve it.

Running a nexus with 4.1 I think here. Mobilinc will be configured later today so if i get an issue, you and I can figure it out.
arw01
 
Posts: 32
Joined: Sun Dec 09, 2012 12:05 pm

Re: Force Close: Cannot access My Settings on Android 4.2

Postby AdminWes » Sat Dec 15, 2012 12:28 pm

Sounds good. Interested in your results to see how it goes.

Wes
AdminWes
Site Admin
 
Posts: 2040
Joined: Sat Feb 07, 2009 2:52 pm

Next

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest