Lollipop?

Submit your bug reports here.

Re: Lollipop?

Postby rick.curl » Sun Nov 23, 2014 7:19 pm

The ISY Dashboard is different than the Admin Console.

Yep- I'm running the dashboard, but having trouble finding the server settings.
rick.curl
 
Posts: 5
Joined: Sun Nov 23, 2014 5:40 pm

Re: Lollipop?

Postby mwareman » Sun Nov 23, 2014 9:30 pm

When in the dashboard, Click 'Configuration' (the wrench icon near the top-right of the window).
Click 'Network'
Under 'HTTPS Server Settings' select something other than SSL3, and something higher than 'Low' for strength.

I have TLS 1.2 and 'All' selected and have not had any issues with clients connecting. The ISY will reboot after you change these settings.

HTTPS Client settings will affect how the network module initiates HTTPS connections. If you have SSL3 selected there you may have issues connecting to third party sites as they start disabling SSL3. You would be wise to change that up to at least TLS 1.0 as well.

Michael.
mwareman
 
Posts: 82
Joined: Sun Jul 29, 2012 5:22 pm

Re: Lollipop?

Postby AdminWes » Mon Nov 24, 2014 3:04 pm

Thanks Michael!

Wes
AdminWes
Site Admin
 
Posts: 2025
Joined: Sat Feb 07, 2009 2:52 pm

Re: Lollipop?

Postby rick.curl » Mon Nov 24, 2014 7:19 pm

Thanks, Michael, but I'm still not seeing those settings. Running the dashboard, I click on Network, and I get a window with two sections, Network Settings and Webserver ports settings.
Under Network settings, I've got IP, Gateway, Subnet Mask, and DNS.
Under Webserver ports settings, I've got HTTP port and HTTPS port. All I can do under HTTPS port is select the port number. What am I missing?
rick.curl
 
Posts: 5
Joined: Sun Nov 23, 2014 5:40 pm

Re: Lollipop?

Postby mwareman » Mon Nov 24, 2014 7:54 pm

It sounds like you may need to drag the bottom of the window down to expand it. The window should look like this:
Image

The window can be sized - but there are no sizing bars (java and all..). When you collapse the window, it can look like this (and I suspect this is what you are seeing):
Image

Michael.
mwareman
 
Posts: 82
Joined: Sun Jul 29, 2012 5:22 pm

Re: Lollipop?

Postby rick.curl » Mon Nov 24, 2014 8:21 pm

Now this is getting weird. My screen looks exactly like the second picture in your post, but when I drag the bottom of the window down it just creates empty space- no HTTPs client or server settings are visible.

I guess I should be asking these questions over on the Universal Devices Forum.

Thanks.

-Rick
rick.curl
 
Posts: 5
Joined: Sun Nov 23, 2014 5:40 pm

Re: Lollipop?

Postby mwareman » Mon Nov 24, 2014 8:47 pm

Is your ISY a PRO model? These options might only be available to PRO models.

If not, is it at 4.2.18?

Prior to 4.2.18 non-pro were locked to SSL3. 4.2.18 changed non-pro units to TLS 1.0.

Upshot is, you must be on 4.2.18 if you have a non-PRO ISY, and you have Android 5.

Michael.
mwareman
 
Posts: 82
Joined: Sun Jul 29, 2012 5:22 pm

Re: Lollipop?

Postby rick.curl » Mon Nov 24, 2014 9:01 pm

It's not the PRO model, but it is at 4.2.18. Should I be able to see these extra settings?
rick.curl
 
Posts: 5
Joined: Sun Nov 23, 2014 5:40 pm

Re: Lollipop?

Postby mwareman » Tue Nov 25, 2014 4:40 am

To be honest - I don't know with any confidence. I've had a PRO for a long time now. You would be best off on UDIs forum.

It was my understanding that with 4.2.18 the non-PRO default changed from SSL3/Low to TLS 1.0/Low. However - I've seen some reports over there that some people had to move from Low - which I'm not sure non-PRO lets you do. It may be that Android 5 is now also blocking weak encryption as well - but I've not confirmed that.

Michel over there should be able to answer very quickly for you.
mwareman
 
Posts: 82
Joined: Sun Jul 29, 2012 5:22 pm

Re: Lollipop - HTTPS Issue?

Postby vspete » Mon Dec 08, 2014 7:06 pm

I just upgraded a Nexus 7 to Android 5 and secure access to my ISY is no longer working. My Android 4.4.x device still has access. After reviewing this board, I upgraded my firmware to 4.2.18, no change. I do not have the isy994PRO version so I cannot see or change the TLS server settings.

It appears that Android 5.0 requires a security level above that supported by the non-PRO version of isy994.

For now I will assume this is an ISY issue and will contact Universal Devices. Should additional information be available, please post and I will do so as well after speaking with UDI.
vspete
 
Posts: 2
Joined: Mon Dec 08, 2014 6:57 pm

PreviousNext

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron