Page 1 of 1

ISY Scene & Amazon Echo - not behaving

PostPosted: Wed Jun 07, 2017 10:56 pm
by MJ-san
Greetings! I have finally made the move from Insteon Hub to ISY and Mobilinc. So far, so good... with one niggling exception.

I have a scene that controls 11 insteon modules (various plug-in modules & wall switches) and is linked to buttons on 5 keypadlincs.

Activating the scene from any of the KPLs or from the ISY console or from the mobilinc app is 100% reliable.

Activating _or_ deactivating the scene from Alexa (it was added as a scene and not an Alexa group) is very spotty. Usually 1-3 lights don't come on or don't go off -- it's not consistent.

I've removed several of the switches, reset, and reinstalled, same issue.

I see that in the ISY console - under the KPL buttons - under advanced properties, I can increase Device Communication to 2 or 3 retries (which I have done). I didn't see any way to accomplish that with Alexa.

Any ideas or suggestions? This is greatly affecting the "spousal acceptance factor" :)


Re: ISY Scene & Amazon Echo - not behaving

PostPosted: Thu Jun 08, 2017 7:08 am
by AdminWes
Hi mj,

All three of these items are 100% equal:

- Commanding a scene to turn on/off from Admin Console
- Commanding the same scene to turn on/off from MobiLinc
- Setting a vocal name on the scene and telling Alexa to turn that item on/off

All three issue the exact same command to the ISY. The first thing to check is to verify that the scene Alexa is controlling is the same one being tested in MobiLinc/Admin Console. If it is, then try commanding that scene on and off a few times with MobiLinc/Admin Console. You should see the same kind of scene behavior that you are seeing with Alexa.

It's important when testing to command the scene on/off and not the scene's controller since that may introduce other factors like what the scene controller is actually setting the scene to since the scene controller can be different than the scene itself.


Re: ISY Scene & Amazon Echo - not behaving

PostPosted: Fri Jun 09, 2017 6:52 pm
by MJ-san
It's very strange. Several devices simply would not respond to the scene when the command was issued from the Echo, but were 100% good when tapping the KPL that is the scene controller.

I verified that the KPL was factory reset before migrating from Insteon Hub to ISY.

The only way I can get this to work 100% reliably is to have in one group on Echo all 11 devices _and_ the ISY scene ... in this case "Accents" ... when I say "accents on/off" it works. Sometimes you can see the delay when the ISY issues the scene (with the same 2-3 devices not behaving) and then going off when Echo sending the individual commands after the scene command.

Since it works now, I'm going to just leave well enough alone.

Re: ISY Scene & Amazon Echo - not behaving

PostPosted: Fri Jun 09, 2017 8:21 pm
by AdminWes
Hi mj,

Definitely check the scene from the Admin Console. Command the scene in the Admin Console directly to mimic what Alexa/MobiLinc Connect does in controlling your scene.


Re: ISY Scene & Amazon Echo - not behaving

PostPosted: Sat Dec 09, 2017 9:48 pm
by erodrigu
I have a similar issue in which when I try to turn a scene on, Echo dot just makes a noise and the "blue lights" lit up; if I ask Alexa to turn off the same scene, Alexa says OK but nothing happens. Scene works all the time from the console, mini-remotes or Mobilinc. Any ideas.

Re: ISY Scene & Amazon Echo - not behaving

PostPosted: Mon Dec 11, 2017 7:17 am
by AdminWes
Hi erodrigu,

Please email us at with:
- your ISY's UUID.
- the scene name you are trying to control.
- A screenshot of your Admin Console showing the Spoken name of that scene.