Issues configuring Foscam FI8918W

Post any feedback and comments you have on our IP Camera support.

Issues configuring Foscam FI8918W

Postby MrTinker » Mon Dec 03, 2012 11:18 am

I'm having issues configuring a Foscam FI8918W via the IP Camera plug-in for MobiLinc.

I initially configured MobiLinc with private network info for my ISY 99i and then decided it would be best to re-configure it for secure access from outside the network (so I can reach it when I'm not home). When I initially attempted to configure the Foscam with private network settings, I ran into issues (MobiLinc just quits at the point it tries to select/test a profile), but I searched out the latest firmware and updated the camera (with a reboot at the end of course). I was then able to configure it and have been using it.

When changing over to public network (with port forwarding), I believe it worked and was configured. But it has since stopped and now I'm unable to re-add it. I've tried various things (reboot phone which is an iPhone4 running iOS 6.0.1, reboot of Foscam), but MobiLinc is back to quitting when I attempt to configure this IP camera.

Any ideas?

EDIT: I should add that accessing the camera from the web and via another app on my phone (CamViewer) works just fine (both via the private and public network configurations).
MrTinker
 
Posts: 3
Joined: Mon Dec 03, 2012 11:06 am

Re: Issues configuring Foscam FI8918W

Postby AdminWes » Mon Dec 03, 2012 2:32 pm

With these Foscams and RTSP Profiles selected, we've noticed that that camera can get into a state that prevents good video data from streaming under this specific profile which can cause MobiLinc to quit out. We're looking at ways to protect MobiLinc from this bad video stream. Please note that most other 3rd party apps do not use RTSP and instead only use JPEG.

For the camera, is the camera on Wi-Fi? If it is can you move it to a wired location just for testing purposes? We've seen bad Wi-Fi as a possible reason.

Also, please make sure all other viewers are disconnected from the camera including temporary turning off port forwarding to ensure it's not getting hit from outside sources.

Try adding the camera or setting up the existing camera again.

In MobiLinc, remove the RTSP port setting. This will force MobiLinc to only use the JPEG refresh method instead of defaulting to use RTSP.

Wes
AdminWes
Site Admin
 
Posts: 2084
Joined: Sat Feb 07, 2009 2:52 pm

Re: Issues configuring Foscam FI8918W

Postby MrTinker » Tue Dec 04, 2012 9:30 am

It is on a wired connection and has a static IP address assigned. I don't believe this camera even supports RTSP so I never have entered anything into the RTSP port when configuring it in MobiLinc.

I forgot, I have SecuritySpy also monitoring this camera. I turned that off and was then able to configure it in MobiLinc without an issue. If I restart SecuritySpy and have it monitoring this camera, I assume this behavior could resurface? At least I'll know what it is and how to fix it.
MrTinker
 
Posts: 3
Joined: Mon Dec 03, 2012 11:06 am

Re: Issues configuring Foscam FI8918W

Postby AdminWes » Tue Dec 04, 2012 10:05 am

Interesting. Looks like there's a conflict with that other software package. My guess is that these Foscam cameras don't handle multiple connections well. Not sure how the other software package is using the camera.

If you are interesting in pursuing this, I could connect to your camera from my lab to see why MobiLinc is crashing on configuring the camera with this software package connected and managing the Foscam. I'd be interesting in at least protecting MobiLinc from the crash scenario.

If you would like me to pursue this, please contact me with the camera connection details at support@mobilinc.com

Wes
AdminWes
Site Admin
 
Posts: 2084
Joined: Sat Feb 07, 2009 2:52 pm


Return to Feedback and Comments

Who is online

Users browsing this forum: No registered users and 1 guest

cron