Odd geofence behavior

Post your MobiLinc comments and feedback here.

Odd geofence behavior

Postby mikewu99 » Wed Jul 19, 2017 8:53 am

I have been testing geofencing for the last ten days or so - just set a geofence at home with 100m radius and monitor the notifications (no programs in ISY yet). For the first week things were running pretty well - better than 95% of the time I was getting accurate notifications upon entering and leaving the area.

I am still getting those accurate results when entering and leaving the area. However, the last two nights I started getting large numbers (10-15) of false exit/enter events. The phone was inside the house, plugged into the charger on my bedside table. I don't seem to have the problem when the phone is in other parts of the house. I have a good strong wifi signal, and I live in an area without a high density of wifi (inSSIDer usually only shows one outside network >20dB below mine).

I do have two wifi access points which use the same SSID set to channels 1 and 11. I also have a Sonos network set to channel 6. Not sure if any of these can confuse the geofence.

Any ideas?
mikewu99
 
Posts: 10
Joined: Sat Apr 28, 2012 5:37 am

Re: Odd geofence behavior

Postby AdminWes » Wed Jul 19, 2017 9:05 am

Hi mikewu99,

Unfortunately, we don't have any insight into how iOS does the boundary detection. It's a combination of cell tower radio info/strength plus nearby Wi-Fi SSIDs.

What I'd recommend is to change the radius from 100m to 250 or 300 and see how that performs. That will give iOS more wiggle room to stay within your home radius when the input data (cell/wi-fi) may jitter.

Wes
AdminWes
Site Admin
 
Posts: 2152
Joined: Sat Feb 07, 2009 2:52 pm


Return to MobiLinc Feedback and Comments

Who is online

Users browsing this forum: No registered users and 2 guests

cron