ISY994i - MOBILINC X - AMAZON ECHO ALEXA - Remote and Voice

Post any feedback or questions you have regarding the MobiLinc Connect Service!

ISY994i - MOBILINC X - AMAZON ECHO ALEXA - Remote and Voice

Postby kswison » Thu Jan 09, 2020 12:47 pm

ISY994i - MOBILINC X - AMAZON ECHO ALEXA - Remote and Voice Control Setup (the easy

This was so frustrating for me so I am going to post this for everyone else and hopefully save a bunch of people a lot of time. I'll make it easy for you...

Hours of time that I will never get

I had type this all out while I was doing it so I could follow it backwards if I got in trouble with something. I have edited it for this Forum, much swearing removed.... haha.

I have had my ISY for 7-8 years now. I am not a computer programmer so I struggle a bit with this stuff sometimes.

I have been using the Mobilinc Pro app on my iPhone, then last year some time upgraded to Mobilinc X.

Mobilinc Pro and Mobilinc X are nice apps with good control. Like the upgrade to Mobilinc X.

Issue... I bought and AMAZIN ECHO Alexa device. CRAP ! This is where is all got frustrating. Every thing I read said Alexa needs to connect through the ISY Portal for Alexa to be able to communicate with the ISY. But the problem with that is that the Moblinc X app becomes non-functional and I really like that Mobilinc X app on my iOS. So I did the set up through the ISY Portal and lost my Mobilinc X control access. I spent hours searching and reading all very complicated ways to try and to that to work, some with success some without. After about 4 month I finally found some more time to work on this after the frustration level dropped, and contacted the Mobilinc X guys and asked how to do this. They told me that the Mobilinc X app needs to run the Mobilinc Connect Integration Portal to be able to connect/communicate with the ISY. That I was on the wrong portal. Great... I already knew that... but after a few frustrating emails they noted the fact that Mobilinc X has a SKILLS option for Alexa to add that SKILL and then Alexa can tell Mobilinc X what to do. Cool ! They also told me that Mobilinc X has had this Alexa SKILL for years now. Really ? In all my reading I never saw that information once. Guess I was just not typing, asking the right questions as I did not know exactly what I was looking for technically. Hmmm....

Now it all makes sense. Wow... very simple.

Wish I could have found this information a long time ago. I don't know if that information is just not out there or I didn't know what to search for. Maybe its because no company owns all systems so they don’t want to comment in any detail as to how other systems really tie in due to some perceived liability or they end up with support requests for other companies products when they do that.

Oh well... I figured it out now.

Here is the revisions that I did to get my ISY communicating again with the Mobilinc X app on my iPhone and get Alexa talking to the Mobilinc X app with Mobilinc X talking to the ISY.

Here goes…..

1) I went to my ISY and into the ISY’s Admin Console and to the Configuration tab, then to the Portals tab.

2) I then clicked on the REVOKE the current UDI Portal. It then showed the UDI Portal Registration as Not Registered. If you have never set up a portal on your ISY you can skip steps 1) & 2).

3) I then went to the and logged in and went to My Products. I had previously purchased the Mobilinc Connect Module and it showed that it was deactivated, so I clicked on the Activate button to activate it. Now it shows that it is activated. I guess if I hadn't already purchased that then I would have had to buy the Mobilinc Connect Module.

4) Going back to the ISY’s Admin Console, Configuration tab, Portal tab, I then clicked the Refresh button, but nothing happened.

5) I then went back to the and logged in and went to My Products and noted this note

Note:ISY Portal and MobiLinc Connect are not compatible.

OK, I cannot run both and noted that my ISY Portal Module for Amazon Echo was still active, so I hit the Deactivate button on the ISY Portal Module for Amazon Echo and its now deactivated.

6) Going back to the ISY’s Admin Console, Configuration tab, Portal tab, I then clicked the Refresh button, but nothing happened. Still no portal.

7) Hmmm... Grrr ! Breathe! Deep Breath !

8) I went back to the webpage and under ISY/Tools/Connectivity it now shows “Access has been revokes by owner”. Good, that is removed now. If you did not have any portals set up previously you can skip this step 8).

9) With all that changed, I did not see anything else I could do, so I re-booted (unplugged) the ISY hoping the Mobilinc Connect Portal would take effect. Always reboot ISY devices when changing these types of things.

10) Upon re-boot a window popped up that stated “Would you like to proceed with the following module actions ? Portal Intregration - Mobilinc Connect (21073)", and I clicked YES. It returned another window that stated “SSL request not authenticated [Portal] TCP client resource moved [UDI-MM]."

The only option was to click ‘OK’. Hmmm... Not good. Breathe !

11) I shut down and re-started the Admin Launcher software, went back to Configuration/Portal tab and clicked Refresh. It came up with the same window stating “Would you like to proceed with the following module actions ? Portal Intregration - Mobilinc Connect (21073)", and I clicked YES. This time it responded “ISY will now be rebooted fro the settings to take effect.” Yay ! I clicked OK.

The ISY unit re-booted. (Not sure why it didn't work the first time, but whatever... it worked the second time.)

12) After re-boot I used Admin Launcher to start up the ISY software again and logged in. Now under Configuration/Portals it shows Portal Integration - Mo… Online - Registered. OK, Looks right.

13) I started up the iPhone Mobilinc X app on my iPhone and it showed no ISY, so I went to Settings and then Current Account. It showed 0 ISY hubs. I realized on was on the wrong WIFI in my house (as I have two WIFIs so I switched back the the correct WIFI that the ISY was on and did this again) It brought up the same Current Account. It showed 0 ISY hubs. I tapped on the hub image and it jumped to another window that said “No ISYs on account”. Then hit the ‘+’ sign on the top right corner. It brought up a new window with “Add your ISY to Mobilinc …” and ‘Tap to add”. The MAC address IP address for the ISY displayed matched mine and were correct so I tapped the Add ISY button. The ISY was added to my Mobilinc X account.

14) I tested the Mobilinc X app and it once again controls my ISY devices like it did before I switched to the UDI Portal for my Alexa set up. So that is working again. I'm getting somewhere now. ! Now to get the Alexa side resolved.

15) Then on the iPhone I went into the Mobilinc X app and tapped on the Lighting icon, then tapped on one of my lights, then tapped on the pencil Edit button in the top right corner of the screen, and then tapped the Set Spoken Name and added a name for all the devices that I wanted Alexa to control with verbal commands.

16) I then went to the AMAZON ALEXA app and to the Devices tab in the bottom right corner of the screen, then to my Lights icon to review the lights that I had previously set up. It showed all my lights that I had previously set up through the ISY Portal (not the Mobilinc Connect Portal) and all of those lights noted “There was a problem". I tapped on the each light which it brought up details for them and I then tapped on the Settings in the top right, then tapped on the top right Garbage Can to delete the item. I did this with all my lights, switches and plugs etc that were set up thru the old ISY Portal and noted “There was a problem" If you did not have any portals set up previously you can skip this step 16).

17) I then went into Alexa’s SKILLS and searched for Mobilinc and it came up with Mobilinc Smart Home SKILL so I added that SKILL. It required that I login and completed that. Cool ! It then asked me to connect the ISY and showed my ISY’s MAC address, so I selected that and added it. Mobilinc Smart Home SKILL installed and is now set up. Feeling much better about this now!

18) Upon closing that set up window, it brought up the Discover Devices screen so I clicked on the Discover button. Alexa discovered all my devices. Cool ! Then I went through the device set up process for each device. I selected each device individually and hit Set Up Device and the devices were added.

19 ) On the Amazon Alexa app I needed to add some groups of lights for Alexa to turn on and off all at once. So I went to the devices tab in the bottom right corner, it brought up another screen and I tapped the ‘+’ sign in the top right of the screen Add Group. Then Add Device and selected the devices I wanted in that group. I set up a group of lights for the living room to turn them on on off and a group for all lights to turn all lights off at once.

20) Then I modified/corrected my Routines in Alexa.

21) I then went to go and talk with Alexa and everything works. Great !

In summary, there are lots of steps to this process with multiple platforms and websites to hit. Took me a while to figure this all out and where what needed to be set up. But now its all working and I can once again after 4 months of trial and errors can once again use my Mobilinc X app to remotely control my ISY. I am very happy !

The thing I could not figure out was that if you want to use Mobilinc X app, your need to use the Mobilinc Connect Portal (which I knew) but Alexa needs the UDI Portal, so I read.


Thats the worst thing I could have ever read, "Alexa needs UDI Portal" with respect to getting Alexa to work with the Mobilinc X app. Wrong direction from the get go. The thing that I did not know and could not find information on (for what ever reason) was that Mobilinc X has a SKILL to allow Alexa to tell Mobilinc X what to do.

How simple. Tell Alexa to tell Mobilinc X what to do, and Mobilinc X will set the ISY accordingly.

Cool !

I previously had everything set up and working with my ISY and Mobilinc X on my iPhone prior to setting up the Alexa. Before I change to the UDI Portal for Alexa...

If I had know (when I got the Amazon Echo Alexa) that all I needed to do was add a SKILL to Alexa and she could control my ISY through Mobilinc X I would have been done in minutes instead of the wasting hours reading and testing, etc.

So I really hope this helps out everyone else and that this information is easy to find. Would have saved me hours.

I really like the Mobilnc X app and it was a pain not having it. But its all working now.

Now that this is all running I recommend this setup.

Cheers ! - MOBILINC X
Posts: 1
Joined: Thu Jan 09, 2020 12:36 pm

Re: ISY994i - MOBILINC X - AMAZON ECHO ALEXA - Remote and Vo

Postby wallyyoung » Thu Aug 06, 2020 1:48 pm

Happened to me too! I've spent the last 3 days trying to figure out what I was missing by trying to use the MobiLinc X app on my iPhone. Finally I figured it out this morning about using the MobiLinc Skill in Alexa and NOT the ISY Optimized for Smart Home V3. Once I got that configured, it all started falling into place.

Now I'm searching for a comprehensive guide for how to configure all my existing devices and programs to work with Alexa without having to re-write everything. Can't seem to find out how to make my devices appear in Alexa even though I've added the spoken names. My programs appear in Alexa after I discover them, but not just the devices themselves...
Posts: 1
Joined: Thu Aug 06, 2020 1:41 pm

Re: ISY994i - MOBILINC X - AMAZON ECHO ALEXA - Remote and Vo

Postby rlebel » Tue Aug 25, 2020 5:03 pm

I have the setup you describe - with the Mobilinc portal and Alexa skill. I can set up routines for my Echo/Dots and other voice commands that include ISY devices and programs. But every once in a.while all of the ISY programs get dropped out of routines (perhaps when I have rebooted the ISY?} and I have to go back and set them up again. I like Mobilinc but am wondering if I need to go to the ISY Portal to have a more stable connection to Alexa?
Posts: 6
Joined: Tue Jun 11, 2013 11:04 pm

Re: ISY994i - MOBILINC X - AMAZON ECHO ALEXA - Remote and Vo

Postby AdminWes » Thu Aug 27, 2020 3:24 pm

Hi rlebel,

What's happening is when your ISY reboots, our servers ask your ISY for your configuration to resync. Our servers will try multiple times, but if your ISY keeps responding with empty responses, then our servers will trust that response and clear out your config on our end. This means that when the ISY decides to respond in the future with your program list, our servers update Alexa.

In many cases this means that your SD Card in your ISY might be going bad. What I strongly recommend is to take a good back up of your ISY and replace your SD Card with new Class 10 16GB SD Card.

Site Admin
Posts: 2152
Joined: Sat Feb 07, 2009 2:52 pm

Return to Feedback

Who is online

Users browsing this forum: No registered users and 1 guest