Devices and Scenes are empty

Does MobiLinc report a string a numbers (x.x.x.x) for a device you own? Report it here!

Devices and Scenes are empty

Postby hammr808 » Sat Sep 19, 2009 10:49 pm

I just downloaded the lite version to test out this app. The app found my ISY26 and I enterred the login information. After clicking sync, the wifi icon spins a bit, but no devices or scenes show up in the list. Am I missing something? The ISY IP address and login credentials are correct. Shouldn't the devices and scenes show up?
hammr808
 
Posts: 7
Joined: Sat Sep 19, 2009 10:43 pm

Re: Devices and Scenes are empty

Postby AdminWes » Sun Sep 20, 2009 9:31 pm

Hi hammr808,

You are correct, you should see one device and one scene in the lite version. Do you be any chance have any special characters in the name of your devices? What I mean by speacial characters are characters outside of the A-Z, a-z, and 0-9 in the English alaphbet. I've seen where the XML gets parsed incorrectly with these special characters and will abort the scene or device listing if present.

Please confirm the names of your devices in the ISY java interface. If that isnt' the problem we will dive into it further.

Wes
AdminWes
Site Admin
 
Posts: 2152
Joined: Sat Feb 07, 2009 2:52 pm

Re: Devices and Scenes are empty

Postby hammr808 » Mon Sep 21, 2009 9:59 pm

Hmm. Yes, I did have a few device names with dashes and parens. I have since removed them and still no luck. By choosing HTTPS connection method I do get a message: iLinc Secure Connect Success!. But still no devices or scenes show up in the list. If I try HTTP, I also get nothing. I have confirmed that all devices and scenes contain only spaces, letters, and numbers.
hammr808
 
Posts: 7
Joined: Sat Sep 19, 2009 10:43 pm

Re: Devices and Scenes are empty

Postby AdminWes » Tue Sep 22, 2009 6:43 am

Hi hammr808,

Let's try this if you're up for it. I'll need to look at the under-the-hood information that ISY is reporting to iLinc to see what iLinc is seeing. In order to do this please follow these steps:

1. Log into the ISY-26 and change your username and password to admin/admin
2. Open a DOS command prompt.
3. type "telnet xxx.xxx.xxx.xxx 80" where xxx is your ISY IP address and 80 is the port number (default is port 80) without the "".
4. Immediately following the telnet connection (less then 2 seconds) right-click and paste the following (replace the xxx with your ISY IP address and 80 with the ISY port number if not 80):

POST /services HTTP/1.1
Authorization: Basic YWRtaW46YWRtaW4=
Host: xxx.xxx.xxx.xxx:80
Content-Length: 139
Content-Type: text/xml; charset="utf-8"
SOAPACTION:"urn:udi-com:service:X_Insteon_Lighting_Service:1#GetNodesConfig"

<s:Envelope><s:Body><u:GetNodesConfig xmlns:u="urn:udi-com:service:X_Insteon_Lighting_Service:1"></u:GetNodesConfig></s:Body></s:Envelope>

Please email me the results at wes@mobileintegratedsolutions.com. I'm thinking that there is something in the return results that would cause iLinc to not display any devices.

Thanks,
Wes
AdminWes
Site Admin
 
Posts: 2152
Joined: Sat Feb 07, 2009 2:52 pm

Re: Devices and Scenes are empty

Postby hammr808 » Sat Dec 05, 2009 12:31 am

Hi Wes,
I was just able to free up some time to revisit this trouble I was having. I decided to upgrade my ISY26 from 2.6.x to 2.7. This actually did the trick! iLinc Lite now works normally. Maybe part of my previous 2.6 upgrade was corrupt, I don't know (I did not have any other issues...). 2.7 is now running and iLinc works like a charm. Thanks for your help with this. I haven't decided yet to get the Pro version, but I'm definitely one step closer.
hammr808
 
Posts: 7
Joined: Sat Sep 19, 2009 10:43 pm

Re: Devices and Scenes are empty

Postby AdminWes » Sat Dec 05, 2009 11:44 am

Hi hammr808,

Thanks for letting me know you've got it all working. I apologize for not asking what firmware version you were running. I should have asked as iLinc is only supported under the following firmware releases: Official Release 2.7.0 and the latest beta releases 2.7.6 and 2.7.7.

Glad you've got it all worked out. Let me know if you have any other issues.

Wes
AdminWes
Site Admin
 
Posts: 2152
Joined: Sat Feb 07, 2009 2:52 pm


Return to Device Support in MobiLinc

Who is online

Users browsing this forum: No registered users and 2 guests

cron