Ubiquiti UniFi Video 3.1 RTSP feed

Post any new feature requests you'd like to see with our IP Camera support.

Ubiquiti UniFi Video 3.1 RTSP feed

Postby jamminred » Wed Apr 29, 2015 5:23 am

Recently Ubiquiti released a new update for its NVR software, they have changed quite a few settings as well as a whole new interface. it supports sending the RTSP feed to 3rd party software but I am not able to get it working in Mobilinc. I am able to open the stream with VLC. the problem I am having is I have a specific RTSP link that needs to be input to access these stream which is easy as opening a network stream in VLC and pasting in the RSTP://10.10.10.1/7447/091e2c73-d628-33 ... xxxxxxxx_0 link. is there a way to just paste this link into the camera settings so that mobilinc will authenticate and stream the live video feed.
thank you
jamminred
 
Posts: 2
Joined: Wed Apr 29, 2015 5:15 am

Re: Ubiquiti UniFi Video 3.1 RTSP feed

Postby AdminWes » Wed Apr 29, 2015 10:06 am

Yes!

Select "Custom camera" for the Camera Type setting in MobiLinc. Then:

Scroll down and enter :

/your-generated-rtsp-path

In the “RTSP Addr” field and clear out all other fields after entering in the IP address, port, username/password at the top of the page.

Wes
AdminWes
Site Admin
 
Posts: 2131
Joined: Sat Feb 07, 2009 2:52 pm

Re: Ubiquiti UniFi Video 3.1 RTSP feed

Postby jamminred » Thu Apr 30, 2015 7:17 am

thank you very much, that worked like a charm...
jamminred
 
Posts: 2
Joined: Wed Apr 29, 2015 5:15 am

Re: Ubiquiti UniFi Video 3.1 RTSP feed

Postby AdminWes » Thu Apr 30, 2015 7:44 am

Excellent! Glad to hear it.

Wes
AdminWes
Site Admin
 
Posts: 2131
Joined: Sat Feb 07, 2009 2:52 pm

Re: Ubiquiti UniFi Video 3.1 RTSP feed

Postby h0mersimps0n » Fri Jan 08, 2016 5:44 am

I tried this on the newest version of Mobilinc HD and there is no "RTSP addr" field, only HTTP and only RTSP ports to enter.

How can we use ubiquiti cameras in Mobilinc HD?
h0mersimps0n
 
Posts: 1
Joined: Fri Jan 08, 2016 5:42 am

Re: Ubiquiti UniFi Video 3.1 RTSP feed

Postby AdminWes » Fri Jan 08, 2016 9:39 am

h0mersimps0n,

Make sure to scroll all the way down to the bottom to get to the list of custom URL entries.

Wes
AdminWes
Site Admin
 
Posts: 2131
Joined: Sat Feb 07, 2009 2:52 pm

Re: Ubiquiti UniFi Video 3.1 RTSP feed

Postby mobi » Tue Apr 23, 2019 6:58 pm

In case anyone's interested in integrating with Ubiquiti G3 Cameras using their Ubiquiti NVR, I did the following:
1) In NVR, enable API access for your user, and copy your API key
2) In NVR settings, enable RTSP and note the port (default is 7447)
3) Select camera in NVR and under Video, enable RTSP for the quality level you want and copy the RTSP path ignoring everything prior to the first slash after the port. So the value in the field may be rtsp://nvr-ip:7447/<mycameraid>_0. You basically want the "/<mycameraID>_0", or _1, _2. (those are the high,med and low paths).
4) In Mobilinc, add a camera, set Camera Type to "Custom IP Camera URL"
5) Set "Local HTTP://" to the ip address of your NVR (NOT the camera)
6) Set "Local Port" to 7080
7) Set RTSP Port" to 7447
8) Add "JPEG addr" of "/api/2.0/snapshot/camera/<cameraID>?force=true&apiKey=<apiKey>"
9) Add "RTSP Addr" of "/<cameraID>_1" or whatever you grabbed above from the Camera/Video settings
10) get rid of values in any other fields - no username/pwd required since you're providing your API key for the JPG

When you hit "Next", it will successfully receive a JPEG image. It still wants MJPEG, even though I select Do Not Use, hit Next, and it will successfully grab the RTSP video stream with audio.

The only problem is, back on the list of cameras, it doesn't show snapshots, even though the setup was successful in grabbing the jpeg. It just gives me the spinning wheel over the black square with the MobiLinc logo forever and intermittently says "Trying to reconnect". If you click on it though, you'll get the video feed. I suspect this may have something to do with limitations in the dimensions of the JPEG the app can display and scale for that snapshot view. I don't think the camera itself can send a snap lower than 1080, and the app is probably saying no dice. I thought this might be a file size issue, and you can knock down the jpeg quality of the snap by hacking the camera, but at quality level 1 with its snap size of 45k, it still wouldn't display in the app. Not sure what's going on with it, but if anyone at Mobilinc wants to weigh in, I'd appreciate it.
mobi
 
Posts: 2
Joined: Tue Apr 23, 2019 6:39 pm

Re: Ubiquiti UniFi Video 3.1 RTSP feed

Postby AdminWes » Wed Apr 24, 2019 8:16 am

Hi mobi,

Thanks for the details.

On the multi-cam page, MobiLinc will use MJPEG first and then JPEG. For a custom camera, make sure to clear out the MJPEG address (make sure this is completely blank) and then select "Do Not Use" on the MJPEG page.

MobiLinc will then use JPEG on the multi-cam page and RTSP on the single-camera page.

Wes
AdminWes
Site Admin
 
Posts: 2131
Joined: Sat Feb 07, 2009 2:52 pm


Return to New Feature Requests

Who is online

Users browsing this forum: No registered users and 2 guests